Intermittent dashboards and reports loading issues

Incident Report for gaiia

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 15:10 UTC

Investigating

Our dashboard and analytics provider is experiencing intermittent loading issues, affecting the Analytics module (dashboards and reports). They are currently investigating the issue.
Posted Jun 02, 2026 - 15:09 UTC
This incident affected: Analytics & Reports.